EasyMail Login Issues
Incident Report for RM Internet & E-safety
Resolved
An issue has been identified with one of the front end web servers. We have resolved the problem and users will be able to login to RM Easymail as usual. We are closely monitoring the platform for any further issues.
Posted Apr 02, 2015 - 14:18 BST
Investigating
There is currently an intermittent issue logging in to RM EasyMail, whereby an "Error 500" message is displayed. We are aware of this and currently working to resolve the issue.
Posted Apr 01, 2015 - 11:52 BST